Работа с диалогами в 1С. Диалоги выбора

Работа с диалогами в 1С. Диалоги выбора

0
224
01.04.2020 Александр Суворов

Содержание:

1.    Вариант 1: выбор из списка значений.

2.    Вариант 2: интерактивный подбор файла 1С 8.3.

   

В этой статье будут рассмотрены варианты диалогов выбора для пользователей только в немодальных вариантах (асинхронных) использования. Все данные функции 1С имеют одну форму и тип работы – открывают пользователю интерактивное окно, не останавливая при этом работу по выполнению кода. А затем интерактивный выбор пользователя обрабатывается другой функцией - Оповещением о выборе. Отказ от модальности работы является обязательным условием для возможности работы в программе 1С в веб-клиенте. 

 

1.    Вариант 1. Выбор из списка значений.

 

Если нужно предоставить пользователю выбор значения из списка, то в 1С для данной цели нужно использовать функцию ПоказатьВыборИзСписка().


Создаем список значений для выбора, описываем оповещение - функцию, которая будет выполняться после выбора значения. Функция оповещения обязательно должна быть указана с ключевым словом Экспорт. Найти параметры функции: Результат - то, что вернет функция по завершению выбора, ДополнительныеПараметры - Любые параметры, которые хотим дополнительно передать в данную функцию.

 

Пример кода:

&НаКлиенте

Процедура НадписьСтепеньВажностиНажатие(Элемент)

Список = Новый СписокЗначений;

Список.Добавить("Низкая",,,БиблиотекаКартинок.Новости);

Список.Добавить("Средняя",,,БиблиотекаКартинок.НовостиВажные);

Список.Добавить("Высокая",,,БиблиотекаКартинок.НовостиВнимание);

ОповещениеОВыборе = Новый ОписаниеОповещения("ПослеЗакрытияВыбораСтепениВажности", ЭтаФорма);

ПоказатьВыборИзСписка(ОповещениеОВыборе, Список);

КонецПроцедуры

&НаКлиенте

Процедура ПослеЗакрытияВыбораСтепениВажности(Результат,ДополнительныеПараметры) Экспорт

Если Результат<>Неопределено Тогда

Элементы.НадписьСтепеньВажности.Заголовок=Результат;

КонецЕсли;

КонецПроцедуры  

 

2.    Вариант 2. Интерактивный подбор файла 1С 8.3


Чтобы осуществить интерактивный подбор файла 1С 8.3, используется объект ДиалогВыбораФайла, но не метод Выбрать(), а метод Показать(), параметром которого является ОписаниеОповещения. Результат интерактивного выбора - это массив путей доступа к файлам подборки.

 

&НаКлиенте

Процедура ПутьККаталогуНачалоВыбора(Элемент,ДанныеВыбора,СтандартнаяОбработка)

СтандартнаяОбработка = Ложь;

ОповещениеОВыборе = Новый ОписаниеОповещения("ПослеЗакрытияВыбораПутиКаталога", ЭтаФорма);

ДиалогВыбораМассиваФайлов= Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);

ДиалогВыбораМассиваФайлов.МножественныйВыбор=Ложь;

ФильтрРасширения = "(*.txt)|*.txt";

ДиалогВыбораМассиваФайлов.Фильтр = ФильтрРасширения;

ДиалогВыбораМассиваФайлов.Показать (ОповещениеОВыборе);

КонецПроцедуры

&НаКлиенте

Процедура ПослеЗакрытияВыбораПутиКаталога(МассивПутейВыбранныхФайлов, ДополнительныеПараметры) Экспорт

Если МассивПутейВыбранныхФайлов<>Неопределено Тогда

ПутьККаталогу= МассивПутейВыбранныхФайлов[0];

КонецЕсли;

КонецПроцедуры

 

Специалист компании ООО «Кодерлайн»

Александр Суворов

Задать вопрос автору статьи
Тема вопроса*
Ваше имя*
E-mail или телефон*
Ваш вопрос*
 

Добавить комментарий
Текст сообщения*
Защита от автоматических сообщений
 
Теги
#1С: CRM #1С: ERP #1С: ERP Управление строительной организацией #1С: ERP. Управление буровой компанией #1С: WMS Управление складом #1С: Аренда и управление недвижимостью #1С: БУХ #1С: Договорчики #1С: Документооборот #1С: ЗУП #1С: Интеграция #1С: КА #1С: Колледж #1С: Конвертация данных #1С: Модули #1С: Платформа #1С: Розница #1С: Сценарное тестирование #1С: ТОИР #1С: УАТ #1С: УКФ #1С: Университет #1С: УНФ #1С: УПП #1С: Управление строительной организацией #1С: УТ #1С: УХ #1С:ERP #1С.6-НДФЛ #ADO #APACHE #API #com-объекты #Excel #Excel в 1С #GoogleDrive #HTTP #ITIL #Koderline: Управление медиа-холдингом #Koderline: Управление проектами строительства скважин #LINUX #MS SQL Server #WEB #WEB-сервисы 1С #Word #XML #Администрирование 1С #Безопасность сервера #Бесшовная интеграция #БИТ.Финанc #Битрикс24 #Блокировки в 1С #БСП #БУ #Бурение скважин #Бюджетирование #Внедрение #Внедрение ERP #Закрытие месяца #Запросы 1С #Интеграция 1С #КАК ОТРАЖАЮТСЯ ТОВАРЫ В ПУТИ 1С #Как сделать в 1С #Конвертация данных #Корпоративное сопровождение #Лизинг #Лицензии 1С #Механизм Анализа Данных в 1С #Моделирование #Модуль Диадок #МСФО #Налоги #Обмен между базами #Обновления #Оптимизация #Отпуск #Отчетность #Отчеты в 1С #Оценка задач #Перенос данных #Планирование #Полезные обработки #Правила обмена #предопределенные элементы справочников #Проводки 1С #Программирование в 1С #Программные права #Продажи #Производство #Работа с объектами в 1С #Расширение конфигурации #РСБУ #СКД #Соединение COM в 1С платформе #Сравнение конфигураций #Тестирование 1С #Техническое задание #Торговое оборудование #Транспортная логистика #Управление проектами #Финансовый учет #Хранилище настроек #Ценообразование #Экзамен 1С #Яндекс.Касса Email или телефон Работа с объектами в 1С Функциональные опции в 1С
Услуги программиста 1С
Получите специалиста  
для решения всех задач
в области 1С
Программы 1С
Цены и подробное описание программ 1С:Предприятие 8.