Как получить форму на сервере
-

Как получить форму на сервере

0
2117
24.04.2022 Быков Владимир

Содержание:

1.       Краткий обзор клиентской и серверной части работы системы

2.       Способ получить форму на сервере в платформе 1С: Предприятия 1С 8.3  

 

1.      Краткий обзор клиентской и серверной части работы системы


Иногда у программистов возникает необходимость использовать управляемую форму на сервере для выполнения каких-либо задач. На управляемых формах существует клиентская и серверная часть. В модулях, где описывается логика работы создаваемого бизнес-процесса используются директивы &.


&НаСервере

Процедура ПечатьНаСервере()

КонецПроцедуры // ПечатьНаСервере()

&НаКлиенте

Процедура Печать()

КонецПроцедуры // Печать()


С помощью директив определяются к какой части (серверной или клиентской) будут относится процедуры и функции. У серверной и клиентской части есть отличия. Клиентская часть представляет собой интерфейс (форма, кнопки, флажки, табличные части, табличное поле и.т.д) прикладного решения (например,1С Бухгалтерия предприятия, редакция 3.0). Когда пользователь выполняет какие-нибудь действия на клиенте форме на сервере срабатывают обработчики событий. Обработчики событий формы представляют собой процедуры.


&НаКлиенте

Процедура ПриОткрытии()

// Вызывает при открытии формы

КонецПроцедуры // ПриОткрытии()

 

Все действия, которые выполняет пользователь на форме на сервере в 1С вызывают процедуру на клиентской части. Можно также выполнять арифметические действия, работать с реквизитами формы и.т.п.


&НаКлиенте

Процедура Печать(Команда)

         // Здесь описывается логика обработки данных информационной базы

         // Процедура вызывается нажатием кнопки

КонецПроцедуры


На серверной части выполняется обработка данных, выполняются запросы, регламентные задания (задания по расписанию) и.т.д. Технология разделения на клиентскую и серверную часть позволяет эффективно использовать ресурсы аппаратной части (компьютеров).


Можно сравнить с пультом дистанционного управления для телевизора, DVD-плеера и тому подобное. Пульт дистанционного управления — это клиентская часть, здесь выполняются команды (вызвать меню, переключить канал, вкл/выкл), а серверная часть телевизор, DVD-плеером. На серверной части (телевизор, DVD-плеер) происходит обработка полученных команд с пульта дистанционного управления.


Клиент-серверный вариант работы платформы 1С: Предприятия версии 8.3 поддерживает трехзвенную архитектуру. Когда клиентское приложение это один компьютер, кластер серверов другой компьютер, а данные хранятся на третьем компьютере. Нужно обратить внимание, что для работы пользователя с прикладным решением не требует высоких требований к аппаратной части. Основная нагрузка ложится на серверную часть.  


2.      Способ получить форму на сервере в платформе 1С: Предприятия 1С 8.3


Рассмотрим способ получить форму на сервере. Напишем процедуру, которая будет вызываться кнопкой «Демонстрация». Получим форму на сервере в 1С и выведем в заголовок формы текст «Привет Мир!». Открыть

форму на сервере невозможно.


В модуле управляемой формы

&НаСервере

Процедура ДемонстрацияНаСервере()

     ОбработкаОбъект= РеквизитФормыВЗначение("Объект");

//ЭтаФорма- это форма клиентского приложения. Передавать форму на //сервер в процедуру ДемонстрацияНаСервере()

     ОбработкаОбъект.ДемонстрацияНаСервере(ЭтаФорма);

КонецПроцедуры

 

&НаКлиенте

Процедура Демонстрация(Команда)

     ДемонстрацияНаСервере();

КонецПроцедуры

 

В модуле объекта

&НаСервере

Процедура ДемонстрацияНаСервере(Форма)   Экспорт

         Форма.Заголовок= "Привет Мир!";

КонецПроцедуры

   

Специалист компании «Кодерлайн»

Быков Владимир

Задать вопрос автору статьи
Тема вопроса*
Ваше имя*
E-mail или телефон*
Ваш вопрос*
 

Добавить комментарий
Текст сообщения*
Защита от автоматических сообщений
 
Теги
#1С: CRM #1С: ERP #1С: ERP Управление строительной организацией #1С: ERP. Управление буровой компанией #1С: WMS Управление складом #1С: Аренда и управление недвижимостью #1С: БУХ #1С: Договорчики #1С: Документооборот #1С: ЗУП #1С: Интеграция #1С: КА #1С: Колледж #1С: Конвертация данных #1С: Модули #1С: Платформа #1С: Розница #1С: Сценарное тестирование #1С: ТОИР #1С: УАТ #1С: УКФ #1С: Университет #1С: УНФ #1С: УПП #1С: Управление строительной организацией #1С: УТ #1С: УХ #1С:ERP #1С:БГУ #1С:БП #1С.6-НДФЛ #ADO #APACHE #API #canonical #com-объекты #Excel #Excel в 1С #GoogleDrive #Googleаккаунт #HTTP #ITIL #Koderline: Управление медиа-холдингом #Koderline: Управление проектами строительства скважин #LINUX #MS SQL Server #WEB #WEB-сервисы 1С #Word #XML #Администрирование 1С #акты в 1С #Безопасность сервера #Бесшовная интеграция #БИТ.Финанc #Битрикс24 #Блокировки в 1С #БСП #БУ #Бурение скважин #Бухгалтерская отчётность в МСФО #Бюджетирование #Внедрение #Внедрение ERP #Закрытие месяца #Запросы 1С #Интеграция 1С #КАК ОТРАЖАЮТСЯ ТОВАРЫ В ПУТИ 1С #Как сделать в 1С #Конвертация данных #Корпоративное сопровождение #Лизинг #Лицензии 1С #Механизм Анализа Данных в 1С #Моделирование #Модуль Диадок #МСФО #Налоги #Обмен между базами #Обновления #Операции в 1С #Оптимизация #Отпуск #Отчетность #Отчеты в 1С #Оценка задач #Перенос данных #Планирование #Полезные обработки #Правила обмена #предопределенные элементы справочников #Принцип работы 1С #Проводки 1С #Программирование в 1С #Программные права #Продажа ТМЦ #Продажи #Производство #Работа с объектами в 1С #Расширение конфигурации #РСБУ #С # #СКД #Соединение COM в 1С платформе #Соединение СОМ в 1С платформе #Сравнение конфигураций #Тестирование 1С #Техническое задание #Типы данных ссылки #Торговое оборудование #Транспортная логистика #Управление проектами #Финансовый учет #Хранилище настроек #Ценообразование #Экзамен 1С #Яндекс-диск или Google-диск #Яндекс.Касса 1С под Linux 1С:УНФ Email или телефон Работа с объектами в 1С Функциональные опции в 1С
Услуги программиста 1С
Получите специалиста  
для решения всех задач
в области 1С
Программы 1С
Цены и подробное описание программ 1С:Предприятие 8.