KoderLine
Обслуживание и внедрение
Наш Facebook Наш Instagram Наш YouTube
+7 (495) 374 55 29
KoderLine
KoderLine
Использование произвольных отборов на базе 1C...

Использование произвольных отборов на базе 1C макета СКД во внешних обработках на примере очистки картинок справочника «Номенклатура» в 1C

0
381
27.09.2019 Алексей Новоточинов

Содержание:

1.       Как использовать 1C макет СКД

2.       Как использовать таблицу значений в реквизитах формы 1С 8.3 

 

1.    Как использовать 1C макет СКД


Часто необходимо делать отборы объектов по различным условиям. Для этого как нельзя лучше подходит схема 1C компоновки данных. Допустим, мы хотим очистить картинки номенклатуры и 1С присоединенные файлы по некоторым условиям, определяемым пользователем, т.е. хотим получить форму как на рисунке:




Делаем 1C макет СКД, где пропишем запрос к справочнику номенклатура в 1С. Можем добавить дополнительное поле для более детального отбора в отобранных объектах.




В настройках выбираем детальные записи и в выбранные поля помещаем поле Ссылка.




На закладке Отбор можем указать первоначальные отборы, хотя делать это необязательно, т.к. пользователь сам сможет его изменять.




Далее делаем форму и реквизит 1С 8.3 типа КомпоновщикНастроекКомпоновкиДанных (в примере он называется КомпоновщикНастроекСКД), и реквизит АдресСхемы, чтобы меньше «дергать» объекты.


Выводим на форму элемент системы Объект – КомпоновщикНастроекСКД – Настройки – Отбор (при необходимости ставим признак сохранения).  




2. Как использовать таблицу значений в реквизитах формы 1С 8.3

 

Создаем макет типа 1С «Схема компоновки данных» (в примере он называется макет).

Делаем таблицу значений в реквизитах формы 1с 8.3 и размещаем на форме (при необходимости).


Далее процедуры:

&НаСервере

Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

               

                РеквизитОбъект = РеквизитФормыВЗначение("Объект");

               

                Схема = РеквизитОбъект.ПолучитьМакет("Макет");

               

                АдресСхемы = ПоместитьВоВременноеХранилище(Схема, УникальныйИдентификатор);

                КомпоновщикНастроекСКД.Инициализировать(Новый ИсточникДоступныхНастроекКомпоновкиДанных(АдресСхемы));    

                КомпоновщикНастроекСКД.ЗагрузитьНастройки(Схема.НастройкиПоУмолчанию);

КонецПроцедуры

И команду «Заполнить» с обработчиками (для заполнения нашей таблицы для показа, при необходимости).

&НаСервере

Процедура ЗаполнитьНаСервере()

 

                СхемаКомпоновкиДанных = ПолучитьИзВременногоХранилища(АдресСхемы);

               

                КомпоновщикНастроек = Новый КомпоновщикНастроекКомпоновкиДанных;

                КомпоновщикНастроек.Инициализировать(

                               Новый ИсточникДоступныхНастроекКомпоновкиДанных(СхемаКомпоновкиДанных));

                КомпоновщикНастроек.ЗагрузитьНастройки(КомпоновщикНастроекСКД.ПолучитьНастройки());

                              

                КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;

                МакетКомпоновки = КомпоновщикМакета.Выполнить(

                               СхемаКомпоновкиДанных,

                               КомпоновщикНастроекСКД.ПолучитьНастройки(),,,

                               Тип("ГенераторМакетаКомпоновкиДанныхДляКоллекцииЗначений"));        

               

                ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;

                ПроцессорКомпоновки.Инициализировать(МакетКомпоновки);

               

                ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВКоллекциюЗначений;

                ТаблицаРезультата = Новый ТаблицаЗначений;

                ПроцессорВывода.УстановитьОбъект(ТаблицаРезультата);

                ПроцессорВывода.Вывести(ПроцессорКомпоновки);

                ТаблицаНоменклатуры.Загрузить(ТаблицаРезультата);

КонецПроцедуры

&НаКлиенте

Процедура Заполнить(Команда)

                ЗаполнитьНаСервере();

КонецПроцедуры

Далее обрабатываем полученную таблицу так, как нам необходимо по заданию. В приложенной обработке использование на примере очистки картинок и присоединенных файлов справочника «Номенклатура» для 1С:УТ 11, ERP и т.д.

 

Специалист компании ООО «Кодерлайн» 

Алексей Новоточинов.

Задать вопрос автору статьи
Тема вопроса*
Ваше имя*
E-mail или телефон*
Ваш вопрос*
 

Добавить комментарий
Текст сообщения*
Защита от автоматических сообщений
 
Теги
#1С: CRM #1С: ERP #1С: ERP Управление строительной организацией #1С: ERP. Управление буровой компанией #1С: WMS Управление складом #1С: Аренда и управление недвижимостью #1С: БУХ #1С: Договорчики #1С: Документооборот #1С: ЗУП #1С: Интеграция #1С: КА #1С: Колледж #1С: Конвертация данных #1С: Платформа #1С: Розница #1С: Сценарное тестирование #1С: ТОИР #1С: УАТ #1С: УКФ #1С: Университет #1С: УНФ #1С: УПП #1С: Управление строительной организацией #1С: УТ #1С: УХ #1С.6-НДФЛ #ADO #APACHE #API #com-объекты #Excel #GoogleDrive #HTTP #ITIL #Koderline: Управление медиа-холдингом #Koderline: Управление проектами строительства скважин #LINUX #MS SQL Server #WEB #WEB-сервисы 1С #Word #XML #Администрирование 1С #Безопасность сервера #Бесшовная интеграция #БИТ.Финанc #Битрикс24 #Блокировки в 1С #БСП #БУ #Бурение скважин #Бюджетирование #Внедрение #Внедрение ERP #Закрытие месяца #Запросы 1С #Интеграция 1С #КАК ОТРАЖАЮТСЯ ТОВАРЫ В ПУТИ 1С #Как сделать в 1С #Конвертация данных #Корпоративное сопровождение #Лизинг #Лицензии 1С #Моделирование #МСФО #Налоги #Обмен между базами #Обновления #Оптимизация #Отпуск #Отчетность #Отчеты в 1С #Оценка задач #Перенос данных #Планирование #Полезные обработки #Правила обмена #Проводки 1С #Программирование в 1С #Программные права #Продажи #Производство #Работа с объектами в 1С #Расширение конфигурации #РСБУ #СКД #Соединение COM в 1С платформе #Сравнение конфигураций #Тестирование 1С #Техническое задание #Торговое оборудование #Транспортная логистика #Управление проектами #Финансовый учет #Ценообразование #Экзамен 1С #Яндекс.Касса Email или телефон Работа с объектами в 1С Функциональные опции в 1С
Услуги программиста 1С
Получите специалиста  
для решения всех задач
в области 1С
Программы 1С
Цены и подробное описание программ 1С:Предприятие 8.