KoderLine
Обслуживание и внедрение
Наш Facebook Наш Instagram Наш YouTube
+7 (495) 374 55 29
KoderLine
KoderLine

Пример обмена 1С OData

0
1339
28.08.2019 Роман Барабанов

Содержание:

1. Как работает OData в 1С?

2. Соединение с http-сервером

   

Появилась необходимость «подружить» 1С справочники конфигураций и в силу того, что эти конфигурации отличаются платформами, на которых работают, соединение через COM не работает, пришла идея использовать интерфейс 1С OData, который по итогу для такой задачи оказался более быстрым решением, нежели создание правил обмена данными.  


1. Как работает OData в 1С?


Все начинается с публикации базы. OData это, по сути, сервис, который позволяет видеть метаданные в ответах на 1С http запросы. Чтобы его включить, необходимо опубликовать базу. Можно не всю и не полностью, а только данный сервис.



 

После его публикации нам становится доступен интерфейс, к которому мы уже можем обращаться через браузер. Но увы, данные объектов конфигурации 1С сейчас «нащупать» не удастся. Для того чтобы открыть доступ к объектам, необходимо воспользоваться функцией: 


УстановитьСоставСтандартногоИнтерфейсаOData(МассивОбъектов);

В МассивОбъектов необходимо поместить метаданные файла, например, так:

МассивОбъектов =Новый Массив;

МассивОбъектов.Добавить(Метаданные.Справочники.Номенклатура);


После этого мы можем считать, что базу-«приемник» мы уже настроили. Теперь необходимо наладить передачу данных. Стоит упомянуть, что конфигурации у нас переписанные, так что мы добавили в нужный нам справочник реквизит для гуида из передатчика. Добавили константы для передатчика, чтобы можно было легко менять базы с тестовой на боевую.

 

2. Cоединение с http-сервером

 

Так как нам необходимо открыть соединение с http-сервером делаем это стандартным образом:


      Адрес = Константы.код_АдресODataДО.Получить();

      Логин = Константы.код_ЛогинOData.Получить();

      Пароль = Константы.код_ПарольOData.Получить();

     

      Соединение = Новый HTTPСоединение(

      Адрес, // сервер (хост)

      80, // порт

      Логин, // пользователь для доступа к серверу

      Пароль, // пароль для доступа к серверу

      , // здесь указывается прокси, если он есть

      , // таймаут в секундах, 0 или пусто - не устанавливать

      // защищенное соединение, если используется https

      );

Далее код, который сам обмен и проводит:


ТелоЗапроса = "/" + База+ "/odata/standard.odata/Catalog_Портфели?$filter=ГУИД_УПП eq '" + Ссылка.УникальныйИдентификатор() + "'&$format=json";

      Запрос = Новый HTTPЗапрос(ТелоЗапроса);

      Результат = Соединение.Получить(Запрос);

      Ответ = Результат.ПолучитьТелоКакСтроку();

     

В коде выше мы просто создаем запрос по соединению, который обращается к справочнику портфели с фильтром по Гуиду 1С. Также указываем, что ответ нам необходим в формате данных json. В ответе мы получаем нужный нам элемент. В случае если он пустой, значит необходимо создавать новый, иначе обновлять.

 

      ЧтениеJson = Новый ЧтениеJSON;

      ЧтениеJson.УстановитьСтроку(Ответ);

      Соответствие = ПрочитатьJSON(ЧтениеJSON,Истина);

      Массив= Соответствие["value"];

      Если Массив.Количество() = 0 Тогда

            Ref_Key = Соответствие["Ref_Key"]

      Иначе

            Ref_Key = Массив[0]["Ref_Key"];

      КонецЕсли;

     

      //Заголовки для запросов

      Заголовки = Новый Соответствие();

      Заголовки.Вставить("Content-Type", "application/json");

      Если Ref_Key = Неопределено Тогда //СоздатьНовыйЭлемент

            ЗапросHTTP = Новый HTTPЗапрос( "/" + База+ "/odata/standard.odata/Catalog_аск_Портфели?$format=json", Заголовки);

            HTTPМетод = "POST";

      Иначе   //ОбновляемЭлемент                                    

            ЗапросHTTP = Новый HTTPЗапрос( "/" + База+ "/odata/standard.odata/Catalog_аск_Портфели(guid'"+ Ref_Key + "')?$format=json", Заголовки);

            HTTPМетод = "PATCH";

      КонецЕсли;


Если результат пустой, то нам необходим POST запрос 1С. В нем нам не нужно указывать конкретный элемент, который мы хотим создать. А вот с патчем ситуация другая. Необходимо строго указать элемент. Для этого воспользуемся гуидом 1С, который мы уже получили в ответе. Вне зависимости от этого нам необходимо создать данные для записи. Этим мы дальше и занимаемся.

     

      //Формируем данные для записи

      ЗаписьJSON = Новый ЗаписьJSON;

      ПараметрыJSON = Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Авто,"",Истина);    

      ЗаписьJSON.УстановитьСтроку(ПараметрыJSON);

      Структура = Новый Структура;

      Структура.Вставить("Description",Ссылка.Наименование);

      Структура.Вставить("Code",Ссылка.Код);

      Структура.Вставить("ГУИД_УПП",Строка(Ссылка.Ссылка.УникальныйИдентификатор()));

      Структура.Вставить("DeletionMark",Ссылка.ПометкаУдаления);

      ЗаписатьJSON(ЗаписьJSON, Структура); // ОтправляемыеДанные обязательны в этом случае

      СтрокаДляТела = ЗаписьJSON.Закрыть();

     

      //Отправляем запрос на обновления или создания

      ЗапросHTTP.УстановитьТелоИзСтроки(СтрокаДляТела,КодировкаТекста.UTF8, ИспользованиеByteOrderMark.НеИспользовать);

      ОтветHTTP = Соединение.ВызватьHTTPМетод(HTTPМетод, ЗапросHTTP);

      СтруктураОтвета = Новый Структура;

      СтруктураОтвета.Вставить("КодСостояния", ОтветHTTP.КодСостояния);

     

Выше мы отправляем это в наш приемник. Если удалось получить ответ сервера, который находится в диапазоне между 200 и 299 включительно, – обмен прошел, чего не скажешь об остальных кодах.

 

      Если ОтветHTTP.КодСостояния < 200 или ОтветHTTP.КодСостояния >= 300 Тогда

            ЗаписьЖурналаРегистрации("ОбменСДО-oData",УровеньЖурналаРегистрации.Ошибка,ПланыОбмена.oDataДокументооборот,Ссылка,

            "Ошибка "+ ОтветHTTP.КодСостояния+ символы.ПС+ОтветHTTP.ПолучитьТелоКакСтроку("UTF-8"));

            //Сообщить(" Ошибка "+ ОтветHTTP.КодСостояния+ символы.ПС+ОтветHTTP.ПолучитьТелоКакСтроку("UTF-8"));

            Возврат Ложь;

      Иначе

            Возврат Истина;

      КонецЕсли;

     

Помимо таких простых обменов справочниками сейчас можно создавать записи в регистрах сведений, создавать документы и даже проводить их. Об этом, возможно, мы подробно расскажем в следующих статьях.


Специалист компании ООО «Кодерлайн» 

Роман Барабанов.

Задать вопрос автору статьи
Тема вопроса*
Ваше имя*
E-mail или телефон*
Ваш вопрос*
 

Добавить комментарий
Текст сообщения*
Защита от автоматических сообщений
 
Теги
#1С: CRM #1С: ERP #1С: ERP Управление строительной организацией #1С: ERP. Управление буровой компанией #1С: WMS Управление складом #1С: Аренда и управление недвижимостью #1С: БУХ #1С: Договорчики #1С: Документооборот #1С: ЗУП #1С: Интеграция #1С: КА #1С: Колледж #1С: Конвертация данных #1С: Платформа #1С: Розница #1С: Сценарное тестирование #1С: ТОИР #1С: УАТ #1С: УКФ #1С: Университет #1С: УНФ #1С: УПП #1С: Управление строительной организацией #1С: УТ #1С: УХ #1С.6-НДФЛ #ADO #APACHE #API #com-объекты #Excel #GoogleDrive #HTTP #ITIL #Koderline: Управление медиа-холдингом #Koderline: Управление проектами строительства скважин #LINUX #MS SQL Server #WEB #WEB-сервисы 1С #Word #XML #Администрирование 1С #Безопасность сервера #Бесшовная интеграция #БИТ.Финанc #Битрикс24 #Блокировки в 1С #БСП #БУ #Бурение скважин #Бюджетирование #Внедрение #Внедрение ERP #Закрытие месяца #Запросы 1С #Интеграция 1С #КАК ОТРАЖАЮТСЯ ТОВАРЫ В ПУТИ 1С #Как сделать в 1С #Конвертация данных #Корпоративное сопровождение #Лизинг #Лицензии 1С #Моделирование #МСФО #Налоги #Обмен между базами #Обновления #Оптимизация #Отпуск #Отчетность #Отчеты в 1С #Оценка задач #Перенос данных #Планирование #Полезные обработки #Правила обмена #Проводки 1С #Программирование в 1С #Программные права #Продажи #Производство #Работа с объектами в 1С #Расширение конфигурации #РСБУ #СКД #Соединение COM в 1С платформе #Сравнение конфигураций #Тестирование 1С #Техническое задание #Торговое оборудование #Транспортная логистика #Управление проектами #Финансовый учет #Ценообразование #Экзамен 1С #Яндекс.Касса Email или телефон Работа с объектами в 1С Функциональные опции в 1С
Услуги программиста 1С
Получите специалиста  
для решения всех задач
в области 1С
Программы 1С
Цены и подробное описание программ 1С:Предприятие 8.