KoderLine
Обслуживание
и внедрение
Наш Facebook Наш Instagram Наш YouTube
+7 (495) 374 55 29 Обратный звонок
Печатная форма форматированного документа в ф...

Печатная форма форматированного документа в формате Word без использования com объектов

0
2252
26.12.2016 Тюсин Владимир
  Screenshot_1.jpg   
     
 

   Поступила задача разработки печатной формы документа с наклонами, выделением текста и т.д.

Ничего особенного. Получил задачу – исполняй. Но оказалось, что таких печатных форм много. Захотелось облегчить свою жизнь и как-то все оптимизировать. Запустил в свой мозг задачу на сон грядущий и умище с утра выдало такое.

Итак, как мне создать печатную форму 1С и сохранить в формате WORD?

-  Поле HTML документа – это что? Обычная строка.

- Можно использовать возможности объекта ТекстовыйДокумент? Можно.

После таких умозаключений разделил макет, тип ТекстовыйДокумент  с HTML разметкой на области (#Область Имя области <Содержимое> #КонецОбласти) . 
 
  Screenshot_2.jpg
Screenshot_3.jpg   
 
     
  И набросал две простенькие функции. Жизнь стала прекрасна  
     
 

Функция ПолучитьОбласть(МакетHTML,ИмяОбласти)

        ТекОбласть = МакетHTML.ПолучитьОбласть(ИмяОбласти);

        //Удаляем строки с определением области  #Область, #КонецОбласти

        ТекОбласть.УдалитьСтроку(1);

        ТекОбласть.УдалитьСтроку(ТекОбласть.КоличествоСтрок());

        Возврат ТекОбласть;

КонецФункции

Функция ВывестиОбласть(Область,Параметры = Неопределено)

        Текст = Область.ПолучитьТекст();

        Если ТипЗнч(Параметры) = Тип("Структура") и Параметры.Количество() Тогда

               Для каждого Эл из Параметры Цикл

                       Текст = СтрЗаменить(Текст,"["+Эл.Ключ+"]",Эл.Значение);

               КонецЦикла;

        КонецЕсли;

        Возврат Текст;

КонецФункции 
 
     
  Далее простая обработка.   
     
  Например:   
     
 

Функция ПолучитьТекстHTML()

        МакетHTML = РеквизитФормыВЗначение("Объект").ПолучитьМакет("МакетПечати");

       

        ОбластьШапка           = ПолучитьОбласть(МакетHTML,"Шапка");

        ОбластьШапкаТаблицы    = ПолучитьОбласть(МакетHTML,"ШапкаТаблицы");

        ОбластьСтрока          = ПолучитьОбласть(МакетHTML,"Строка");

        ОбластьПодвал          = ПолучитьОбласть(МакетHTML,"Подвал");

        ПараметрыШапки         = Новый Структура("Номер,Дата,Контрагент"

                                              ,"000001"

                                              ,"01.01.2016"

                                              ,"ООО Рога и Копыта");

        ТекстHTML      = ТекстHTML+Символы.ПС

                               + ВывестиОбласть(ОбластьШапка,ПараметрыШапки);

                              

        ТекстHTML      = ТекстHTML+Символы.ПС

                               + ВывестиОбласть(ОбластьШапкаТаблицы);

        СуммаИтог = 0;

        Для Сч= 1 по 10 Цикл

               Рандом  = Новый ГенераторСлучайныхЧисел(150*Сч);

               Артикул = Рандом.СлучайноеЧисло(10000,30000);

               Рандом = Новый ГенераторСлучайныхЧисел(15*Сч);

               Цена           = Окр(Рандом.СлучайноеЧисло(100,30000)/100,2);

               Рандом = Новый ГенераторСлучайныхЧисел(Сч);

               Количество             = Рандом.СлучайноеЧисло(1,20);

               Сумма                  = Окр(Цена*Количество,2);

               СуммаИтог              = СуммаИтог+Сумма;

               ПараметрыСтроки = Новый Структура("НомерСтроки,Артикул,Товар,Количество,Цена,Сумма"

                                              ,Сч

                                              ,Артикул

                                              ,"Товар такойто "+ Строка(Сч)

                                              ,Количество

                                              ,Формат(Цена,"ЧДЦ=2")

                                              ,Формат(Сумма,"ЧДЦ=2"));

               ТекстHTML = ТекстHTML+Символы.ПС

                                 + ВывестиОбласть(ОбластьСтрока,ПараметрыСтроки);   

        КонецЦикла;

        ПараметрыПодвала = Новый Структура("Сумма",Формат(СуммаИтог,"ЧДЦ=2"));                

       

        ТекстHTML = ТекстHTML+Символы.ПС

                         + ВывестиОбласть(ОбластьПодвал,ПараметрыПодвала);

        Возврат ТекстHTML             

КонецФункции 
 
     
 

ПС: Как получить макет с HTML разметкой в 1С? Все знают, что 1С таблицу или документ WORD можно сохранить как HTML.

Так же мы можем сохранить результат c расширением doc  и получим обычный документ WORD 
 
     
 

    Владимир Тюсин,

разработчик компании ООО «Кодерлайн» 

 

Задать вопрос автору статьи
Тема вопроса*
Ваше имя*
E-mail или телефон*
Ваш вопрос*
 

Добавить комментарий
Текст сообщения*
Защита от автоматических сообщений
 
Теги
#1С: CRM #1С: ERP #1С: ERP Управление строительной организацией #1С: ERP. Управление буровой компанией #1С: WMS Управление складом #1С: Аренда и управление недвижимостью #1С: БУХ #1С: Договорчики #1С: Документооборот #1С: ЗУП #1С: Интеграция #1С: КА #1С: Колледж #1С: Конвертация данных #1С: Платформа #1С: Розница #1С: Сценарное тестирование #1С: ТОИР #1С: УАТ #1С: УКФ #1С: Университет #1С: УНФ #1С: УПП #1С: Управление строительной организацией #1С: УТ #1С: УХ #ADO #APACHE #API #com-объекты #Excel #GoogleDrive #HTTP #ITIL #Koderline: Управление медиа-холдингом #Koderline: Управление проектами строительства скважин #LINUX #MS SQL Server #WEB #WEB-сервисы 1С #Word #XML #Администрирование 1С #Безопасность сервера #Бесшовная интеграция #БИТ.Финанc #Битрикс24 #Блокировки в 1С #БСП #БУ #Бурение скважин #Бюджетирование #Внедрение #Внедрение ERP #Закрытие месяца #Запросы 1С #Интеграция 1С #Как сделать в 1С #Конвертация данных #Корпоративное сопровождение #Лизинг #Лицензии 1С #Моделирование #МСФО #Налоги #Обмен между базами #Обновления #Оптимизация #Отпуск #Отчетность #Отчеты в 1С #Оценка задач #Перенос данных #Планирование #Полезные обработки #Правила обмена #Проводки 1С #Программирование в 1С #Программные права #Продажи #Производство #Расширение конфигурации #РСБУ #СКД #Сравнение конфигураций #Тестирование 1С #Техническое задание #Торговое оборудование #Транспортная логистика #Управление проектами #Финансовый учет #Ценообразование #Экзамен 1С #Яндекс.Касса Email или телефон
Услуги программиста 1С
Получите специалиста  
для решения всех задач
в области 1С
Программы 1С
Цены и подробное описание программ 1С:Предприятие 8.
Яндекс.Метрика