Добавление собственных автоподстановок в про...
-

Добавление собственных автоподстановок в программе 1С:Документооборот

0
4352
16.03.2021 Максим Федоров

Содержание:

  1. Постановка проблемы
  2. Решение задачи в 1С:Документооборот

В программе 1С Документооборот встроено достаточно большое количество типовых автоподстановок.

 

Автоподстановки в программе 1С Документооборот

Автоподстановки в программе 1С Документооборот


Но на этапе доработок иногда возникает необходимость добавить свои "автоподстановки". Например, в процессе согласования должен участвовать еще какой-нибудь сотрудник. В данной статье будет подробно описано, как решить эту задачу в конфигурации 1С:Документооборот.  


1.     Постановка проблемы

 

У предприятия сложная структура подчинения и для эффективности процесса согласования необходимо, чтобы тот или иной документ согласовывал не только руководитель подразделения, но и руководитель направления. Для этого у "Внутреннего документа" добавили дополнительный реквизит документа – Руководитель направления. Но также необходимо добавить и автоподстановку "Руководитель направления". Значение этой "автоподстановки" должны получаться из дополнительного реквизита документа "Руководитель направления".

 

расширения в 1С 8 Документооборот

Добавление дополнительного реквизита документа  

    

2. Решение задачи в 1С:Документооборот

 

Для разработки в программной части 1С:Документооборот и добавления этой автоподстановки мы создадим расширение "ДополнительныеАвтоподстановки".

 

Создание расширения в 1С 8 Документооборот

Создание расширения в 1С 8 Документооборот


Теперь необходимо описать механизм получения значения нашей автоподстановки. Для этого захватываем в расширение общий модуль "ШаблоныБизнесПроцессовПереопределяемый". Добавляем в него функцию, в которой описываем алгоритм получения автоподстановки.


//            Получает руководителя направления из дополнительного значения дополнительного реквизита "Руководитель направления".

//

//            Параметры:

//                           ДокументОбъект - СправочникОбъект.ВнутреннийДокумент,

//              СправочникОбъект.ВходящийДокумент,

//              СправочникОбъект.ИсходящийДокумент - создаваемый документ.

//

//            Возвращаемое значение:

//                           СправочникСсылка.Пользователи.

//

Функция ДАП_РуководительНаправления(ДокументОбъект) Экспорт

                Если ДокументОбъект.Предметы.Количество()> 0 тогда

                               Предмет = ДокументОбъект.Предметы[0]. Предмет;

                               Если ТипЗнч(Предмет) = Тип("СправочникСсылка.ВнутренниеДокументы") Тогда

                                               Запрос = Новый Запрос;

                                               Запрос.Текст =

                                               "ВЫБРАТЬ

                                               |             ВнутренниеДокументыДополнительныеРеквизиты.Значение КАК Значение

                                               |ИЗ

                                               |             Справочник.ВнутренниеДокументы.ДополнительныеРеквизиты КАК ВнутренниеДокументыДополнительныеРеквизиты

                                               |ГДЕ

                                               |             ВнутренниеДокументыДополнительныеРеквизиты.Ссылка = &Ссылка

                                               |             И ВнутренниеДокументыДополнительныеРеквизиты.Свойство.Наименование = ""Руководитель направления""";

                                               Запрос.УстановитьПараметр("Ссылка", Предмет.Ссылка);

                                               ВыборкаДетальныеЗаписи = Запрос.Выполнить().Выбрать();

                                               Если ВыборкаДетальныеЗаписи.Следующий() Тогда

                                                               Возврат ВыборкаДетальныеЗаписи.Значение;

                                               КонецЕсли;

                               КонецЕсли;

                КонецЕсли;

                Возврат Справочники.Пользователи.ПустаяСсылка();

               

КонецФункции

 

Вызов новой автоподстановки также прописываем в общем модуле "ШаблоныБизнесПроцессовПереопределяемый". Для этого в 1С 8.3 Документооборот аннотацией "Вместо" перехватываем функцию "ПолучитьСписокДоступныхФункций".

 

&Вместо("ПолучитьСписокДоступныхФункций")

Функция ДАППолучитьСписокДоступныхФункций()

                ДоступныеФункции = ПродолжитьВызов();

               

                ДоступныеФункции.Добавить("ШаблоныБизнесПроцессовПереопределяемый.ДАП_РуководительНаправления(Объект)", НСтр("ru = 'Руководитель направления'"));

                Возврат ДоступныеФункции;

КонецФункции

 

С программной частью все готово!

Теперь необходимо зайти в пользовательском режиме работы в 1С:Документооборот.


Открываем выбор автоподстановок и видим, что добавленная автоподстановка в списке не появилась.

 

Чтобы она появилась в списке, необходимо щелкнуть по нему правой клавишей мышки и выбрать "Обновить автоподстановки". После этого наша автоподстановка подтянется сразу же.

 

Как обновить автоподстановки в 1С


Как обновить автоподстановки в 1С 8 Документооборот?

Как обновить автоподстановки в 1С 8 Документооборот?

 

Специалист компании «Кодерлайн»

Максим Федоров

 

Задать вопрос автору статьи
Тема вопроса*
Ваше имя*
E-mail или телефон*
Ваш вопрос*
 

Добавить комментарий
Текст сообщения*
Защита от автоматических сообщений
 
Теги
#1С: CRM #1С: ERP #1С: ERP Управление строительной организацией #1С: ERP. Управление буровой компанией #1С: WMS Управление складом #1С: Аренда и управление недвижимостью #1С: БУХ #1С: Договорчики #1С: Документооборот #1С: ЗУП #1С: Интеграция #1С: КА #1С: Колледж #1С: Конвертация данных #1С: Модули #1С: Платформа #1С: Розница #1С: Сценарное тестирование #1С: ТОИР #1С: УАТ #1С: УКФ #1С: Университет #1С: УНФ #1С: УПП #1С: Управление строительной организацией #1С: УТ #1С: УХ #1С:ERP #1С:БГУ #1С:БП #1С.6-НДФЛ #ADO #APACHE #API #canonical #com-объекты #Excel #Excel в 1С #GoogleDrive #HTTP #ITIL #Koderline: Управление медиа-холдингом #Koderline: Управление проектами строительства скважин #LINUX #MS SQL Server #WEB #WEB-сервисы 1С #Word #XML #Администрирование 1С #акты в 1С #Безопасность сервера #Бесшовная интеграция #БИТ.Финанc #Битрикс24 #Блокировки в 1С #БСП #БУ #Бурение скважин #Бухгалтерская отчётность в МСФО #Бюджетирование #Внедрение #Внедрение ERP #Закрытие месяца #Запросы 1С #Интеграция 1С #КАК ОТРАЖАЮТСЯ ТОВАРЫ В ПУТИ 1С #Как сделать в 1С #Конвертация данных #Корпоративное сопровождение #Лизинг #Лицензии 1С #Механизм Анализа Данных в 1С #Моделирование #Модуль Диадок #МСФО #Налоги #Обмен между базами #Обновления #Оптимизация #Отпуск #Отчетность #Отчеты в 1С #Оценка задач #Перенос данных #Планирование #Полезные обработки #Правила обмена #предопределенные элементы справочников #Проводки 1С #Программирование в 1С #Программные права #Продажи #Производство #Работа с объектами в 1С #Расширение конфигурации #РСБУ #С # #СКД #Соединение COM в 1С платформе #Сравнение конфигураций #Тестирование 1С #Техническое задание #Торговое оборудование #Транспортная логистика #Управление проектами #Финансовый учет #Хранилище настроек #Ценообразование #Экзамен 1С #Яндекс.Касса 1С под Linux 1С:УНФ Email или телефон Работа с объектами в 1С Функциональные опции в 1С
Услуги программиста 1С
Получите специалиста  
для решения всех задач
в области 1С
Программы 1С
Цены и подробное описание программ 1С:Предприятие 8.