Обработчик ожидания

Обработчик ожидания

0
383
18.03.2020 Аскер Жансуев

Содержание:

1.      Варианты подключения Обработчика ожидания

2.      Ограничение механизма обработчика ожидания

 

Обработчик ожидания (формы клиентского приложения) – это процедура модуля формы с директивой компиляции &НаКлиенте, вызываемая с указанным интервалом механизмом платформы 1С, который включается с помощью метода формы клиентского приложения ПодключитьОбработчикОжидания.


Вызов метода доступен в тонком клиенте, веб-клиенте, толстом клиенте.

Параметры:

<ИмяПроцедуры> (обязательный) Тип: Строка. Имя процедуры, подключаемой в качестве обработчика ожидания.


<Интервал> (обязательный) Тип: Число. Интервал времени в секундах с точностью до 1/10 секунды, через который будет осуществляться вызов процедуры (положительное число). Если указано значение меньше 1, то значение третьего параметра должно быть равно Истина.


<Однократно> (необязательный) Тип: Булево. Признак однократного выполнения обработчика ожидания.

Истина – указанный обработчик ожидания будет выполнен один раз. Значение по умолчанию: Ложь.  

 

1.    Варианты подключения Обработчика ожидания

 

Варианты подключения:

Вариант 1. Требуется однократный вызов выполнения какой-либо процедуры с директивой компиляции &НаКлиенте, отложенный на определенное время.


Вариант 2. Требуется регулярный вызов выполнения какой-либо процедуры с директивой компиляции &НаКлиенте с указанной периодичностью. 

 

2.    Ограничение механизма обработчика ожидания

 

Ограничение механизма обработчика ожидания. Сразу оговоримся, что вызов и выполнение процедуры, подключенной через метод ПодключитьОбработчикОжидания, как однократный, так и регулярный, механизмом платформы 1С происходит только в период ожидания системы. Поэтому использовать данный механизм платформы 1С как таймер, либо другой аналогичный инструмент, выполняющий функцию точного отсчета времени при выполнении кода, не следует.

 

Как было сказано выше, в качестве обработчика ожидания (формы клиентского приложения) можно подключить процедуру модуля формы с директивой компиляции &НаКлиенте.


Но если требуется выполнение с помощью данного механизма платформы 1С какой-либо процедуры с директивой компиляции, отличной от директивы &НаКлиенте (например, процедуры модуля данной формы или любой доступной экспортной процедуры конфигурации), то можно просто осуществлять вызов такой процедуры из процедуры-обработчика ожидания. Это справедливо и для случая, когда требуется осуществлять через данный механизм платформы 1С вызов какой-либо функции модуля данной формы или любой доступной экспортной функции конфигурации.

 

Вызов процедуры-обработчика ожидания прекращается с закрытием формы, в которой был подключен обработчик ожидания, либо при вызове метода формы клиентского приложения ОтключитьОбработчикОжидания, в который в качестве параметра передается имя подключенной ранее процедуры-обработчика ожидания.

 

Подключение процедуры-обработчика ожидания для однократного выполнения через указанный интервал:

 
&НаКлиенте
Процедура ПриОткрытии(Отказ)
        // Подключение процедуры-обработчика ожидания для однократного выполнения через интервал в 30 секунд.
        ПодключитьОбработчикОжидания("НашаПроцедураОбработчикОждидания", 30, Истина); 
КонецПроцедуры
 
&НаКлиенте
Процедура НашаПроцедураОбработчикОждидания()
        // Вызов процедуры с директивой компиляции, отличной от директивы &НаКлиенте,
        // через процедуру-обработчик ожидания.
        ПроцедураВызываемаяИзОбработчикаОжиданияВыполняемаяНаСервере();
        
        // Вызов функции, через процедуру-обработчик ожидания.
        ФункцияВызываемаяИзОбработчикаОжидания();
КонецПроцедуры


Подключение процедуры-обработчика ожидания для регулярного выполнения через указанный интервал:

 
&НаКлиенте
Процедура ПриОткрытии(Отказ)
        // Подключение процедуры-обработчика ожидания для регулярного выполнения через интервал в 30 секунд.
        ПодключитьОбработчикОжидания("НашаПроцедураОбработчикОждидания", 30); 
КонецПроцедуры
 
&НаКлиенте
Процедура НашаПроцедураОбработчикОждидания()
        // Вызов процедуры с директивой компиляции, отличной от директивы &НаКлиенте,
        // через процедуру-обработчик ожидания.
        ПроцедураВызываемаяИзОбработчикаОжиданияВыполняемаяНаСервере();
        
        // Вызов функции, через процедуру-обработчик ожидания.
        ФункцияВызываемаяИзОбработчикаОжидания();
КонецПроцедуры
 

Специалист компании «Кодерлайн» 

Аскер Жансуев.

Задать вопрос автору статьи
Тема вопроса*
Ваше имя*
E-mail или телефон*
Ваш вопрос*
 

Добавить комментарий
Текст сообщения*
Защита от автоматических сообщений
 
Теги
#1С: CRM #1С: ERP #1С: ERP Управление строительной организацией #1С: ERP. Управление буровой компанией #1С: WMS Управление складом #1С: Аренда и управление недвижимостью #1С: БУХ #1С: Договорчики #1С: Документооборот #1С: ЗУП #1С: Интеграция #1С: КА #1С: Колледж #1С: Конвертация данных #1С: Модули #1С: Платформа #1С: Розница #1С: Сценарное тестирование #1С: ТОИР #1С: УАТ #1С: УКФ #1С: Университет #1С: УНФ #1С: УПП #1С: Управление строительной организацией #1С: УТ #1С: УХ #1С:ERP #1С.6-НДФЛ #ADO #APACHE #API #com-объекты #Excel #Excel в 1С #GoogleDrive #HTTP #ITIL #Koderline: Управление медиа-холдингом #Koderline: Управление проектами строительства скважин #LINUX #MS SQL Server #WEB #WEB-сервисы 1С #Word #XML #Администрирование 1С #Безопасность сервера #Бесшовная интеграция #БИТ.Финанc #Битрикс24 #Блокировки в 1С #БСП #БУ #Бурение скважин #Бюджетирование #Внедрение #Внедрение ERP #Закрытие месяца #Запросы 1С #Интеграция 1С #КАК ОТРАЖАЮТСЯ ТОВАРЫ В ПУТИ 1С #Как сделать в 1С #Конвертация данных #Корпоративное сопровождение #Лизинг #Лицензии 1С #Механизм Анализа Данных в 1С #Моделирование #Модуль Диадок #МСФО #Налоги #Обмен между базами #Обновления #Оптимизация #Отпуск #Отчетность #Отчеты в 1С #Оценка задач #Перенос данных #Планирование #Полезные обработки #Правила обмена #предопределенные элементы справочников #Проводки 1С #Программирование в 1С #Программные права #Продажи #Производство #Работа с объектами в 1С #Расширение конфигурации #РСБУ #СКД #Соединение COM в 1С платформе #Сравнение конфигураций #Тестирование 1С #Техническое задание #Торговое оборудование #Транспортная логистика #Управление проектами #Финансовый учет #Хранилище настроек #Ценообразование #Экзамен 1С #Яндекс.Касса Email или телефон Работа с объектами в 1С Функциональные опции в 1С
Услуги программиста 1С
Получите специалиста  
для решения всех задач
в области 1С
Программы 1С
Цены и подробное описание программ 1С:Предприятие 8.