Как сделать нумерацию счетов-фактур по номеру...
-

Как сделать нумерацию счетов-фактур по номеру реализации

8
8870
26.10.2020 Максим Кригер

Содержание:

1.       Счет-фактура для реализации

2.       Работа с конфигуратором 1С 8.3 

 

1.    Счет-фактура для реализации


Нумерация счетов-фактур в 1С 8.3 происходит сквозным способом. Достаточно один раз не создать счет-фактуру для реализации, и нумерация счетов начнет отличаться. В этой статье рассказывается, как выровнять номера реализаций и нумерацию счетов-фактур через расширение конфигурации. Решение подойдет для любых конфигураций уровня 1С ПРОФ на базе 1С 8.3 (1С УТ 11, 1С БП 3.0, КА 2, ERP 2 и т.д.). 

 

2.    Работа с конфигуратором 1С 8.3

 

1) Переходим в конфигуратор 1С.


2) Открываем конфигурацию 1С 8.3, щелкнув по пиктограмме, указанной на картинке (отмечена стрелкой) или же через меню в 1с 8.3 Конфигурация → Открыть конфигурацию.

 

Работа с конфигуратором 1С 8.3


3) Далее нужно создать расширение.

3.1) Заходим в меню 1С 8.3 “Конфигурация”, далее – “Расширения конфигурации”.


конфигуратор 1С 8.3

 

3.2) В меню расширений конфигурации нужно добавить новое расширение. Имя, синоним и префикс можно задать на свое усмотрение.

 

расширения конфигурации 


3.3) Снимаем флаги “Безопасный режим” и “Защита от опасных действий”.

 

Безопасный режим 


4) Добавляем в созданное расширение документ “Счет-фактура выданный”. Для этого выделяем документ, кликаем правой кнопкой мыши и выбираем “Добавить в расширение”.

 

Защита от опасных действий


4.1) Откроется список созданных расширений конфигурации. Нужно выбрать требуемое расширение и нажать кнопку “Выбрать”.


 список созданных расширений


5) Добавляем в созданное расширение реквизит “ДокументОснование” по аналогии с п.4.

 

ДокументОснование 


6) Открываем модуль объекта документа “Счет-фактура выданный” в нашем расширении. Для этого нажимаем на документ правой кнопкой мыши, выбираем “Открыть модуль объекта”.

 

Счет-фактура выданный       

 

7) Вставляем в модуль объекта следующий код:


&После("ПередЗаписью")

Процедура Расш1_ПередЗаписью (Отказ, РежимЗаписи, РежимПроведения)

            Если НЕ ЗначениеЗаполнено(Ссылка) Тогда

                        Номер = ДокументОснование.Номер;

            КонецЕсли;

КонецПроцедуры

        
Разберем данный код.

 

1) В строке кода “Процедура Расш1_ПередЗаписью (Отказ, РежимЗаписи, РежимПроведения)” Расш1 – это префикс вашего расширения, его необходимо заменить на тот префикс, который вы указывали при создании расширения(п.3.2).

 

2) В коде “Если НЕ ЗначениеЗаполнено(Ссылка) Тогда

                        Номер = ДокументОснование.Номер;

            КонецЕсли;” проверяется условие: если документ не записан в базу данных (ссылка на него не заполнена), то номер счет-фактуры берем из документа реализации (ДокументОснование.Номер).

 

Аналогично в этой процедуре можно создать любое другое условие нумерации счетов-фактур.

 

Осталось только обновить конфигурацию 1С 8.3. Для этого нужно нажать на соответствующую пиктограмму.

 

 модуль объекта документа

 

Проверяем результат:

 

пример документа Счет-фактура выданный


Видим, что номер счет-фактуры совпадает с номером реализации в 1С 8.3. Задача решена!

 

Специалист компании «Кодерлайн»

Максим Кригер

 

Задать вопрос автору статьи
Тема вопроса*
Ваше имя*
E-mail или телефон*
Ваш вопрос*
 

0
Сергей
Спасибо, всё очень подробно!
Имя Цитировать 0
0
Администратор
Здравствуйте! Сергей, спасибо за Ваш комментарий!
Имя Цитировать 0
0
Надежда
Самое огромное Вам спасибо!!! Глобальную проблему прям помогли решить)
Имя Цитировать 0
0
Администратор
Здравствуйте! Спасибо, нам приятно!)
Имя Цитировать 0
0
Александр
Добрый день!
А если была выдана СФ на основании корректировки реализации или на аванс при сквозной нумерации, как тогда выровнять номера по соответствию СФ и Акта реализации.
Имя Цитировать 0
0
Guest
Добрый день! Все получается, спасибо! Но в печатной фоме все равно порядковый номер пишется и в книге продаж тоже. Как исправить? Может я что то не доделала?
Имя Цитировать 0
0
Guest
не будет работать. При создании корректировочной реализации будет номер взят из нее в счет фактуру. А если номер коррек. реализации совпадет с РТиУ, то будет ошибка, что номер счет фактуры не уникальный. Т.е. должен быть один нумератор
Имя Цитировать 0
0
Almi
При создании корректировочной реализации однозначно работать не будет, но если уж делать, то как минимум нужно сделать так:
Код
Если Не Отказ 
   и ЭтоНовый()
   и ТипЗнч(ДокументОснование) = Тип("ДокументСсылка.РеализацияТоваровУслуг") Тогда
   
   УстановитьПривилегированныйРежим(Истина);
   
   ЭтотОбъект.Номер = ДокументОснование.Номер; 
   УстановитьПредставлениеНомера();
   
   Запрос = Новый Запрос;  
   Запрос.УстановитьПараметр("Дата",  ЭтотОбъект.Дата);
   Запрос.УстановитьПараметр("Номер", ЭтотОбъект.Номер);
   Запрос.Текст = 
      "ВЫБРАТЬ ПЕРВЫЕ 1
      |   СчетФактураВыданный.Ссылка КАК Ссылка
      |ИЗ
      |   Документ.СчетФактураВыданный КАК СчетФактураВыданный
      |ГДЕ
      |   СчетФактураВыданный.Дата МЕЖДУ НАЧАЛОПЕРИОДА(&Дата, ГОД) И КОНЕЦПЕРИОДА(&Дата, ГОД)
      |   И СчетФактураВыданный.Номер = &Номер";
   
   РезультатЗапроса = Запрос.Выполнить();
   Выборка = РезультатЗапроса.Выбрать();
   Пока Выборка.Следующий() Цикл
      Текст = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
         НСтр("ru = 'Номер не уникален, уже существует счет-фактура: %1'"),
         Выборка.Ссылка);
      ОбщегоНазначения.СообщитьПользователю(
         Текст,
         ЭтотОбъект,
         ,
         ,
         Отказ);
   КонецЦикла;
   
КонецЕсли;


не благодарите )
Имя Цитировать 0
Добавить комментарий
Текст сообщения*
Защита от автоматических сообщений
 
Теги
# абота Риелторского Агентства #Работа Риелторского Агентства #1С: CRM #1С: ERP #1С: ERP Управление строительной организацией #1С: ERP. Управление буровой компанией #1С: WMS Управление складом #1С: Аренда и управление недвижимостью #1С: БУХ #1С: Договорчики #1С: Документооборот #1С: ЗУП #1С: Интеграция #1С: КА #1С: Колледж #1С: Конвертация данных #1С: Модули #1С: Платформа #1С: Розница #1С: Сценарное тестирование #1С: ТОИР #1С: УАТ #1С: УКФ #1С: Университет #1С: УНФ #1С: УПП #1С: Управление строительной организацией #1С: УТ #1С: УХ #1С:ERP #1С:БГУ #1С:БП #1С:Риелтор #1С.6-НДФЛ #ADO #APACHE #API #canonical #com-объекты #Excel #Excel в 1С #GoogleDrive #Googleаккаунт #HTTP #ITIL #Koderline: Управление медиа-холдингом #Koderline: Управление проектами строительства скважин #LINUX #MS SQL Server #WEB #WEB-сервисы 1С #Word #XML #Администрирование 1С #акты в 1С #Безопасность сервера #Бесшовная интеграция #БИТ.Финанc #Битрикс24 #Блокировки в 1С #БСП #БУ #Бурение скважин #Бухгалтерская отчётность в МСФО #Бюджетирование #Внедрение #Внедрение ERP #Задача для 1С #Закрытие месяца #Запросы 1С #Интеграция 1С #КАК ОТРАЖАЮТСЯ ТОВАРЫ В ПУТИ 1С #Как сделать в 1С #Конвертация данных #Корпоративное сопровождение #Лизинг #Лицензии 1С #Механизм Анализа Данных в 1С #Моделирование #Модуль Диадок #МСФО #Налоги #Обмен между базами #Обновления #Операции в 1С #Оптимизация #Отпуск #Отчетность #Отчеты в 1С #Оценка задач #Перенос данных #Планирование #Полезные обработки #Правила обмена #предопределенные элементы справочников #Принцип работы 1С #Проводки 1С #Программирование в 1С #Программные права #Продажа ТМЦ #Продажи #Производство #Работа с объектами в 1С #Расширение конфигурации #РСБУ #С # #СКД #Соединение COM в 1С платформе #Соединение СОМ в 1С платформе #Сравнение конфигураций #Тестирование 1С #Техническое задание #Типы данных ссылки #Торговое оборудование #Транспортная логистика #Управление проектами #Финансовый учет #Хранилище настроек #Ценообразование #Экзамен 1С #Яндекс-диск или Google-диск #Яндекс.Касса 1С под Linux 1С:УНФ Email или телефон Работа с объектами в 1С Функциональные опции в 1С
Услуги программиста 1С
Получите специалиста  
для решения всех задач
в области 1С
Программы 1С
Цены и подробное описание программ 1С:Предприятие 8.