Использование рекурсии в 1С

Использование рекурсии в 1С

0
509
10.04.2020 Щербаков Кирилл

Содержание:

1.    Понятие рекурсии в 1С

 

Рекурсией в программировании называется явление вызова функции или процедуры по ее же алгоритму выполнения. В случае, когда функция вызывает себя опосредованно, рекурсия называется сложной или косвенной (а не простой или прямой, как в случае непосредственного вызова функцией самой себя).


Из определения рекурсии следует вывод, что во избежание бесконечного увеличения стека вызовов, необходимо предусмотреть условие выхода – условие, при котором очередной рекурсивный вызов не произойдет, что положит начало «заворачиванию» стека, по окончании которого получим конечный результат.

 

&НаКлиенте

Процедура Сосчитать(Команда)

            СчетДоДесяти(Число);

КонецПроцедуры

 

Процедура СчетДоДесяти(НачальноеЧисло)

    Если НачальноеЧисло <= 10 Тогда

        Сообщить(Строка(НачальноеЧисло));

        НачальноеЧисло = НачальноеЧисло + 1;

        СчетДоДесяти(НачальноеЧисло);

    Иначе //выход из рекурсии

                        Сообщить("Счет окончен.");

                        Возврат;

    КонецЕсли;

КонецПроцедуры

 

Результат выполнения команды «Начать» из приведенного примера, можно получить просто используя цикл, а не рекурсию. Такой вариант был бы лучше и с точки зрения производительности, ведь каждый вызов процедуры подразумевает выделение памяти под значения локальных переменных.


Такой счет до десяти – пример линейной рекурсии в 1С. То есть каждый очередной вызов процедуры инициирует лишь один рекурсивный вызов или при выполнении условия выхода не инициирует вовсе.


Каскадная же рекурсия характерна тем, что очередной вызов процедуры может непосредственно инициировать два и более рекурсивных вызова. Примером каскадной рекурсии является алгоритм нахождения числа ряда Фибоначчи по его номеру в ряду:

 

Функция ПолучитьЧислоРядаФибоначчиПоНомеру(НомерЧислаВРяду)

            Если НомерЧислаВРяду < 2 Тогда

                        Возврат НомерЧислаВРяду;

            КонецЕсли;

           

            Возврат ПолучитьЧислоРядаФибоначчиПоНомеру(НомерЧислаВРяду - 1) + ПолучитьЧислоРядаФибоначчиПоНомеру(НомерЧислаВРяду - 2)

КонецФункции

 

&НаКлиенте

Процедура Фибоначчи(Команда)

            Сообщить(ПолучитьЧислоРядаФибоначчиПоНомеру(Число));

КонецПроцедуры  


2.    Как используется рекурсия в 1С

 

Практическим примером использования рекурсии в 1С является алгоритм получения верхнеуровнего элемента справочника с иерархией элементов.


Получим для указанной организации главную организацию в иерархии элементов. Здесь условие выхода - Элемент.Уровень() = 0:

 

&НаКлиенте

Процедура УзнатьГлавнуюОрганизацию(Команда)

           

            Если Не ЗначениеЗаполнено(Организация) Тогда

                        Сообщить("Укажите Организацию");

                        Возврат;

            КонецЕсли;

           

            УзнатьГлавнуюОрганизациюНаСервере();

           

КонецПроцедуры

 

&НаСервере

Процедура УзнатьГлавнуюОрганизациюНаСервере()

           

            Если Организация.Уровень() = 0 Тогда

                        Сообщить("Указана организация верхнего уровня");

            КонецЕсли;

           

            ГоловнаяОрганизация = ПолучитьРодителя(Организация);

           

            Сообщить(ГоловнаяОрганизация);

           

КонецПроцедуры

 

&НаСервереБезКонтекста

Функция ПолучитьРодителя(Элемент)

           

            Если Элемент.Уровень() = 0 Тогда

                        Возврат Элемент;

            КонецЕсли;

           

            Возврат ПолучитьРодителя(Элемент.Родитель);

           

КонецФункции

 

 

Другой обычный случай использования рекурсии в 1С – обход дерева значений. Устройство этой иерархической структуры позволяет реализовать такой алгоритм:

 

&НаСервере

Процедура ОбойтиРекурсивно(Дерево)

           

            Для Каждого Строка Из Дерево.Строки Цикл

                       

      Сообщить(Строка.Организация);

            Если Строка.Строки.Количество()>0 Тогда //Иначе выход из рекурсии

                       

         ОбойтиРекурсивно(Строка);

                       

            КонецЕсли;

           

КонецЦикла;

КонецПроцедуры

 

Если у строки два или более подчиненных, наблюдаем каскадную рекурсию.


Специалист компании ООО «Кодерлайн»

Щербаков Кирилл

 

Задать вопрос автору статьи
Тема вопроса*
Ваше имя*
E-mail или телефон*
Ваш вопрос*
 

Добавить комментарий
Текст сообщения*
Защита от автоматических сообщений
 
Теги
#1С: CRM #1С: ERP #1С: ERP Управление строительной организацией #1С: ERP. Управление буровой компанией #1С: WMS Управление складом #1С: Аренда и управление недвижимостью #1С: БУХ #1С: Договорчики #1С: Документооборот #1С: ЗУП #1С: Интеграция #1С: КА #1С: Колледж #1С: Конвертация данных #1С: Модули #1С: Платформа #1С: Розница #1С: Сценарное тестирование #1С: ТОИР #1С: УАТ #1С: УКФ #1С: Университет #1С: УНФ #1С: УПП #1С: Управление строительной организацией #1С: УТ #1С: УХ #1С:ERP #1С.6-НДФЛ #ADO #APACHE #API #canonical #com-объекты #Excel #Excel в 1С #GoogleDrive #HTTP #ITIL #Koderline: Управление медиа-холдингом #Koderline: Управление проектами строительства скважин #LINUX #MS SQL Server #WEB #WEB-сервисы 1С #Word #XML #Администрирование 1С #Безопасность сервера #Бесшовная интеграция #БИТ.Финанc #Битрикс24 #Блокировки в 1С #БСП #БУ #Бурение скважин #Бюджетирование #Внедрение #Внедрение ERP #Закрытие месяца #Запросы 1С #Интеграция 1С #КАК ОТРАЖАЮТСЯ ТОВАРЫ В ПУТИ 1С #Как сделать в 1С #Конвертация данных #Корпоративное сопровождение #Лизинг #Лицензии 1С #Механизм Анализа Данных в 1С #Моделирование #Модуль Диадок #МСФО #Налоги #Обмен между базами #Обновления #Оптимизация #Отпуск #Отчетность #Отчеты в 1С #Оценка задач #Перенос данных #Планирование #Полезные обработки #Правила обмена #предопределенные элементы справочников #Проводки 1С #Программирование в 1С #Программные права #Продажи #Производство #Работа с объектами в 1С #Расширение конфигурации #РСБУ #СКД #Соединение COM в 1С платформе #Сравнение конфигураций #Тестирование 1С #Техническое задание #Торговое оборудование #Транспортная логистика #Управление проектами #Финансовый учет #Хранилище настроек #Ценообразование #Экзамен 1С #Яндекс.Касса Email или телефон Работа с объектами в 1С Функциональные опции в 1С
Услуги программиста 1С
Получите специалиста  
для решения всех задач
в области 1С
Программы 1С
Цены и подробное описание программ 1С:Предприятие 8.